好用的Node.js版本管理工具nvm可任意切换对应的Node.js版本

原创 野人  2021-07-17 09:01  阅读 9 次

起因

项目中要用到PSD.js的插件,但是这个插件要求Node.js版本要大于0.4.x,小于0.7.0(如下图),所以没办法,只能按照要求去下载对应的版本了,毕竟谁叫自己菜呢。

经过和结果

想起早些时候,好像是有看到过包管理工具,于是在搜索引擎的帮助下很快就找到了,叫nvm,于是跟着教程一顿操作,安装完了nvm后,也在里面下载了对应的Node.js版本,但是就是不能生效(也就是在cmd这类终端中,直接输入node/npm,提示“不是内部或外部命令,也不是可运行的程序或批处理文件”,那就有问题了。)

就再认真看了下安装教程,没有错啊,重试了两次还是不行,只好去官方的Github仓库反馈下,哦吼,看到有朋友遇到了同样的问题,说是安装的路径中含有空格这些,我对比了下我的,还确实有。

而且官方是推荐最最好是,安装在磁盘的根目录,比如(D:/,E:/,这类的地方,不容易出错),原文是这样说的:

更多具体的回答请参考:https://github.com/coreybutler/nvm-windows/issues/548

看了上面的回答,聪明的我,结果当然是,顺利解决了啦,我可真厉害(嘻嘻)。

本文地址:http://www.yerenwz.com/4370.html
版权声明:本文为原创文章,版权归 野人 所有,欢迎分享本文,转载请保留出处!

发表评论